[Mesa-dev] [status][help]pipe-video on Loongson3A(mipsel) platform with r600

fykcee1 at gmail.com fykcee1 at gmail.com
Wed Aug 3 22:41:10 PDT 2011


2011/8/3 Andy Furniss <andyqos at ukfsn.org>:
>> My mplayer reads /usr/lib/XvMCConfig, after I providing that file,
>> libXvMCr600.so is loaded by mplayer.
> Does it work now then?
No, it renders a corrupted playback

I guess that may be related with driver or DRM stack, after playback,
my desktop corrupts
(Similar with "-vc ffmpeg12vdpau -vo vdpau).

> I don't know how close to rv670 rs780 is, but I have artifact issues with my
> rv670 that don't show with my rv790.
> If you can get it to display I would interested what -
> http://www.andyqos.ukfsn.org/Pendulum.mpg
No, this renders a corrupted playback
but doesn't cause my desktop corruption.

>>>> Generally r600 pipe-video still has rendering and functional issues. If
>>>> you
>>>> just want to test fair enough, but if you are trying to make your system
>>>> play h264 that it can't currently the best thing you could do is compile
>>>> svn
>>>> mplayer which now has ffmpeg h264 multithread support so -
>>>> mplayer -lavdopts threads=4 will use all of your cores.
>> Tried, not make big difference at first glance. (P.S.  can mplayer
>> show fps in OSD?)
>> That still doesn't use all CPU power(even with thread=8) according to top.
1. Option          "SwapbuffersWait" "off"
2. xvattr -a XV_VSYNC -v 0
3. Use metacity instead of compiz
4. "mplayer -nosound -benchmark -lavdopts threads=N  -vo xv

threads=1 vs threads=4, the result showed little difference:
* 1 thread: 1519.509s
* 4 threads: 1486.825s
The details http://dev.lemote.com/files/upload/software/temp/thread_1.log
vs http://dev.lemote.com/files/upload/software/temp/thread_4.log

- cee1

More information about the mesa-dev mailing list