[Mesa-dev] [PATCH V2] mesa: fix GL_MAX_NAME_LENGTH query for tessellation shaders
Marek Olšák
maraeo at gmail.com
Tue Jan 5 15:57:47 PST 2016
Negating that expression would make it more readable. There are also a
lot of unnecessary parentheses. If you at least remove the
parentheses:
Reviewed-by: Marek Olšák <marek.olsak at amd.com>
Marek
On Tue, Jan 5, 2016 at 11:23 PM, Timothy Arceri
<timothy.arceri at collabora.com> wrote:
> ping
>
> This fixes some piglit subtests for ARB_program_interface_query.
>
>
> On Thu, 2015-12-24 at 13:16 +1100, Timothy Arceri wrote:
>> V2: fix alignment
>> ---
>> src/mesa/main/shader_query.cpp | 7 ++++++-
>> 1 file changed, 6 insertions(+), 1 deletion(-)
>>
>> diff --git a/src/mesa/main/shader_query.cpp
>> b/src/mesa/main/shader_query.cpp
>> index a1813ac..3a730af 100644
>> --- a/src/mesa/main/shader_query.cpp
>> +++ b/src/mesa/main/shader_query.cpp
>> @@ -765,7 +765,12 @@ static bool
>> add_index_to_name(struct gl_program_resource *res)
>> {
>> bool add_index = !(((res->Type == GL_PROGRAM_INPUT) &&
>> - res->StageReferences & (1 <<
>> MESA_SHADER_GEOMETRY)));
>> + res->StageReferences &
>> + ((1 << MESA_SHADER_GEOMETRY) |
>> + (1 << MESA_SHADER_TESS_CTRL) |
>> + (1 << MESA_SHADER_TESS_EVAL))) ||
>> + ((res->Type == GL_PROGRAM_OUTPUT) &&
>> + res->StageReferences & (1 <<
>> MESA_SHADER_TESS_CTRL)));
>>
>> /* Transform feedback varyings have array index already appended
>> * in their names.
> _______________________________________________
> mesa-dev mailing list
> mesa-dev at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/mesa-dev
More information about the mesa-dev
mailing list