Setting up a data connection mmcli with PLS8-X

matthew stanger stangerm2 at
Wed Jun 15 00:29:53 UTC 2016

I'm trying to get MM to work with the the Cinterion PLS8-X on Linux 3.14.
I've tried using two different methods (ttyACM vs. qmi_wwan) but can't get
to the end state of making a data connection and was hoping someone could
tell me which way would be best and maybe hint at what I might be doing

For the first (ttyACM) which seems like the default supported route. When I
attach the modem via USB to linux it loads cdc_acm & cdc_ether drivers. I
get /dev/ttyACM* devices and can queue modem info without issue via 'mmcli
-m 0'. I then try to do 'mmcli -m 0 --simple-connect="apn=broadband"'
(correct apn for AT&T) which works and --simple-status shows connected.
This is as far as I get. Running udhcpc -i usb0 fails to get an ip address
and I'm not really sure why.

I also tried using the qmi_wwan route by back-porting the vendor/product id
to qmi_wwan and option drivers and adding usb4 to the option driver
blacklist. MM comes up and I can queue 'mmcli -m 0' correctly but I get
/dev/USB(1)(3)(4)(6)(8) enumerations and no /dev/cdc-wdm which means no
wwan... and that's the end of that.

Really my goal is just to get a data connection, via command line - no gui
or network manager at this point, any idea's on what I can try, something
I'm doing wrong or missing?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ModemManager-devel mailing list