[Openchrome-devel] Kernel with KMS support might conflict with X.org keyboard driver

Mario Rugiero mrugiero
Sat Sep 24 12:49:15 PDT 2011

2011/9/22 Mario Rugiero <mrugiero at gmail.com>

> 2011/9/22 Mario Rugiero <mrugiero at gmail.com>
>> 2011/9/21 Mario Rugiero <mrugiero at gmail.com>
>>> 2011/9/21 James Simmons <jsimmons at infradead.org>
>>>> > Hi, I think I might have found a bug with the KMS branch.
>>>> Hi! Thank you for trying the new code.
>>>> > I'm currently testing with these two configs:
>>>> > - Latest x.org-edgers kernel + KMS branch X.org driver
>>>> This is with the default Ubuntu kernel. Can you post your dmesg. Thank
>>>> you. Have you tried trunk with this setup as well. Did you see any
>>>> problems?
>>>> > - Latest git revision from James Simmons's tree for the kernel, and
>>>> latest KMS revision X.org driver
>>>> Is this with KMS enabled? By default it is not enabled since support is
>>>> still lacking.
>>>> > With the latter configuration, I get roughly 1/3 of the times I boot
>>>> the computer, no keyboard when X.org is running (I can use the keyboard in
>>>> text mode).
>>>> Very strange bug. Possible memory over flow corrupting data. Do you
>>>> see this with the openchrome xorg driver trunk using the new kernel
>>>> driver? Can you post your dmesg and Xorg logs for me to look at. Thanks.
>>>> Right now I'm not on that computer, so I'll post the logs later. I
>>> didn't try with default trunk yet, but I did try with KMS enabled and
>>> disabled (i.e. without specifying) and got the same result with both
>>> options.
>> A question: which configurations should I try? Just the failing ones with
>> KMS enabled and disabled and with trunk and KMS branch?
>> Or even the working ones? That would be a huge amount of logs (like 24, if
>> I'm calculating it right).
> OK, I got some logs.
> First, I must say that my chipset is a K8M800, which I forgot to tell.
> Second, I found another strange bug, when using KMS kernel with KMS
> enabled, independently of using trunk or KMS branch of the DDX driver, I
> randomly get hang ups while activating ATA units, with which ctrl+alt+supr
> can not reboot the machine (and I can't remember the other key combination
> to use in that cases), so I must hard reboot, and I couldn't get logs from
> that cases.
> Third, I tried maximum three reboots to get a particular result, except
> while trying to boot correctly with KMS enabled and trunk DDX driver, which
> I've tried around ten times to avoid both bugs, until I got it.
> If there isn't some log, it means I couldn't get that result with that
> combination of factors.
> Well, I'll attach the logs I've been able to get.
> The names of the folders I've made inside the tar.gz means the kernel used,
> the ddx driver used, and when relevant, if KMS was enabled and if I got a
> fully working boot or if it failed.
> Thanks for your efforts :)
I send it again, now to the list, because I forgot to add the address the
first time :S
Thanks for your efforts, all of you :)
------------ pr?xima parte ------------
Se ha borrado un adjunto en formato HTML...
URL: http://wiki.openchrome.org/pipermail/openchrome-devel/attachments/20110924/c39fcef4/attachment.html

More information about the Openchrome-devel mailing list