[pulseaudio-discuss] Mic not working with PA

Colin Guthrie gmane at colin.guthr.ie
Wed Sep 23 03:43:58 PDT 2009

'Twas brillig, and remrot at gmail.com at 23/09/09 09:56 did gyre and gimble:
>  I have a problem getting the mic to work on a Toshiba 100 with an 
> ALC861 chipset (no builtin mic). I tried Ubuntu 9.04 and 9.10 Alpha with 
> the same results: the mic works during the live session but stops 
> working after installation. Because of that, it's very likely not a bug 
> within the ALSA driver but either a wrong configuration or a bug in a 
> higher level application like PA. I've already filed a bug report on 
> launchpad, but got no response so far:
> https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/434511
> However, after doing a lot of search, it seems that there are more 
> people with similar problems and they "solved" them mostly by 
> uninstalling PA. I don't really want to do that (especially not in 
> Ubuntu Karmic, since it's deeply integrated) so I decided to ask for 
> help on this mailing list. Unfortunately, it's not my laptop and I only 
> have access to it for the next few days. So, if anyone has some 
> suggestions on how to get the mic working (or track down the bug) that 
> would be really helpful...

The starting point would be to provide the output from:

pacmd list

Then to double check in pavucontol (the newest version - e.g. 0.9.9) 
which supports ports.

1. On the "Configuration" tab, you should have a profile selection drop 
down for your card. This should allow you to choose how your hardware 
works. e.g. you may have picked a 5.1 output profile which disables 
sound input (due to hardware limitations) or simply selected an output 
only profile. If so you would generally not get a list of devices under 
the "Input Devices" (with the default filter).

If that doesn't solve the issue, look on the "Input Devices" tab and you 
should see the recording device. if there are multiple ports available 
then you should get a drop down there that you can use to switch ports.

This may solve it for you.

If all this fails, try a fresh user account or remove your ~/.pulse 
folder. If the live session works, then it could just be some thing in 
your config that's causing it, so trashing ~/.pulse is the easiest fix 
there (although double check /etc/pulse for differences in the files 
there from the live version too.




Colin Guthrie

Day Job:
   Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
   Mandriva Linux Contributor [http://www.mandriva.com/]
   PulseAudio Hacker [http://www.pulseaudio.org/]
   Trac Hacker [http://trac.edgewall.org/]

More information about the pulseaudio-discuss mailing list