[pulseaudio-discuss] Mic not working with PA

remrot at gmail.com remrot at gmail.com
Fri Sep 25 04:11:46 PDT 2009

Hi again!

 I found a workaround for the dead mic: adding 'position_fix=1' to the
option list brought it back to life! However, it's still different from
within the live system. The recorded stream is very quiet and contains
significant noise, unlike in the live system where volume and quality were
very good, even with the capture device almost muted! So, it still remains a
very strange bug and I wrote another mail to the ALSA developer list
containing additional information collected with their info-script. You can
take a look at it there if you like (the devel, not the users list). I'm
curious if I'll ever get a response...

Thx for your help



2009/9/24 Colin Guthrie <gmane at colin.guthr.ie>

> 'Twas brillig, and remrot at gmail.com at 24/09/09 11:16 did gyre and gimble:
>> I've already tried to determine the exact parameters for the alsa modules,
>> but I don't know to do that (lsmod and dmesg don't help). The only thing I
>> can do is compare the alsa-base.conf files where the options are stored, but
>> these files are identical, except for the 'probe_mask'. But without that I
>> have neither sound output nor a capture device. I also compared the
>> alsa-info files but again the only difference I see is 'probe_mask' related.
>> To be honest, the more I investigate the less sense this all makes to me.
>> Yesterday I tried again to record from within the live session and it works
>> perfectly. Even the mic volume is very loud without a boost. This is driving
>> me crazy...
>> Here are the differences within the /etc/pulse/daemon.conf file (the other
>> files are identical)
>> daemon.conf:
>> ; rlimit-rtttime = 1000000
>> vs
>> ; rlimit-rttime = 1000000
>> ; flat-volumes = yes
>> vs
>> flat-volumes = no
>> I assume the first is a typo?? Anyway, it's commented out. And you already
>> noticed the flatvolumes thing, so nothing new there....
> Yeah I fixed the typo the other day :p
> Flat volumes shoudn't affect things at all but the other flag relating to
> HW volume control is telling. It basically tells me that the underlying alsa
> stuff is different in some what, so I'm swaying slightly on the side of it
> being an alsa issue in some capacity... possibly compounded by other issues
> tho'.
> I guess you could test the recording at the alsa level with some arecord
> commands may help confirm it but even then I'm still not sure.
>  I've posted to the alsa users mailing list, maybe one of the people there
>> has got an idea. Thanks again for your help, if you've got any other
>> suggestions I'll be happy to try them out!
> Cool. I'll keep an eye open there too.
> Col
> --
> Colin Guthrie
> gmane(at)colin.guthr.ie
> http://colin.guthr.ie/
> Day Job:
>  Tribalogic Limited [http://www.tribalogic.net/]
> Open Source:
>  Mandriva Linux Contributor [http://www.mandriva.com/]
>  PulseAudio Hacker [http://www.pulseaudio.org/]
>  Trac Hacker [http://trac.edgewall.org/]
> _______________________________________________
> pulseaudio-discuss mailing list
> pulseaudio-discuss at mail.0pointer.de
> https://tango.0pointer.de/mailman/listinfo/pulseaudio-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20090925/9503c427/attachment.htm>

More information about the pulseaudio-discuss mailing list