[pulseaudio-discuss] rygel mediaserver

Gunnar Aastrand Grimnes gunnar.grimnes at dfki.de
Wed Apr 13 11:11:26 PDT 2011

A tiny bit more detail - I tried running wireshark while trying to play 
the stream, the WDTV asks for the stream:

HEAD /listen/source/alsa_output.pci-0000_00_06.1.analog-stereo.monitor 

And pulseaudio responds:

HTTP/1.0 500 Internal Server Error\n


The body returned contains no more useful info.

Testing the same with curl give the same result:

curl -I 
HTTP/1.0 500 Internal Server Error
Connection: close
Content-Type: text/html; charset=utf-8
Cache-Control: no-cache
Expires: 0
Server: pulseaudio/0.9.22

Actually HTTP GET'ing the stream with curl works fine.

I made a ticket: http://pulseaudio.org/ticket/933


- Gunnar

On 12/04/11 21:50, Gunnar Aastrand Grimnes wrote:
>> I think you have to load module-protocol-http as well (not sure I've got
>> the name totally correct).
> That's the one I meant when I said "I have also enabled the http-tcp
> module," - it's called module-http-protocol-tcp
>> I tried it with my PS3 but never got very far (it defo did try to talk
>> to the http module tho')
>> If you get it working with your WDTV box just by loading http protocol,
>> please report back and I'll tweak paprefs.
> No such luck. Running pa in a console it says:
> I: socket-server.c: TCP connection accepted by tcpwrap.
> I: client.c: Created 12 "HTTP client (TCP/IP client from
> I: client.c: Freed 12 "HTTP client (TCP/IP client from
> immediately, and the WDTV says "unable to play the selected file".
> With my LG HB405SU there is on such message, but rygel says:
> ** (rygel:10171): WARNING **: rygel-http-request.vala:91: Invalid seek
> request
> When I try to play the stream.
> Cheers,
> - Gunnar
> _______________________________________________
> pulseaudio-discuss mailing list
> pulseaudio-discuss at mail.0pointer.de
> https://tango.0pointer.de/mailman/listinfo/pulseaudio-discuss

More information about the pulseaudio-discuss mailing list