[pulseaudio-discuss] Pulseaudio per-user instance unusable

Joel A Fernandes agnel.joel at gmail.com
Thu Jul 7 19:51:25 PDT 2011


I will be as descriptive as possible about a certain issue pulseaudio
I have had keeping audio devices "busy" and discuss what I have tried
and what I see.

I'm using a 2.6.32 kernel (have also used a 2.6.39 kernel) with
PulseAudio 0.9.15 (Angstrom distribution) on a BeagleBoard (tried C5
and -xM).

The problems appear to be two-fold.
- Firstly, the utilities: pactl, pacmd etc are unable to connect to
the pulse server most of the times (so its kind of intermittent)
- Second, aplay cannot use pulseaudio as it throws errors as mentioned
below, and, cannot not-use pulseaudio as it keeps the sound devices
busy :) So we're stuck!

I have tried running pulseaudio in both system and user modes.

* When started up as a per-user instance ,which is started up by
start-pulseaudio-x11 like so:
 /usr/bin/pulseaudio --start "$@"

The pulseaudio server daemonizes but not always. Sometimes I have to
delete the .pulse-cookie file and .pulse/ directory to have it
daemonize. Only once it does daemonize, pactl is able to connect to it
and list modules but again audio players can't have it play anything.
Further, -vv -log-level pulseaudio options don't seem to generate very
 interesting debug information that helps.

strace shows that it opens the sound device and then calls pause()
waiting for events to occur. This causes no one else to be able to
open the sound devices! pulseaudio just keeps it busy though its not
using the devices! suspend-on-idle module doesn't get loaded, though
the default.pa has it set.

I can confirm that the shared library "suspend-on-idle module" is
_not_ being loaded by looking at its process memory map
(/proc/../maps) though the /etc/default.pa file does have the option
enabled! I cannot use pactl to check if the module is loaded because
it doesn't connect to the pulse server (as mentioned above), but
atleast the memory map tells me it isn't.

* In system mode (passing --system)
clients such as pactl are able to connect and list modules etc and the
sound devices are not kept busy.

However audio players that use pulseaudio (by settings in
/etc/asound.conf), report an error such as "Unable to create stream:
No such entity, Unable to set hw params". The distribution doesn't
have an asound.conf preconfigured so this isn't a problem as such but
I thought I'd mention it anyway.

 So pulseaudio --system doesn't work but atleast it _does not_ keep
sound devices open. So other applications can still use alsa to open
sound devices without going through pulseaudio.

For reference, I have uploaded my /etc/default.pa and /etc/system.pa
config files to:

I would appreciate any suggestions on what could be a possible cause,
and a viable solution to the problem.


More information about the pulseaudio-discuss mailing list