[pulseaudio-discuss] [BUG] Using bluez 5.5 & pulseaudio a bluetooth headset cannot be used as a recording device.

Mikel Astiz mikel.astiz.oss at gmail.com
Mon Jun 10 06:12:29 PDT 2013

Hi Alex,

On Sat, Jun 8, 2013 at 8:45 PM, Alexander Winnig
<vernehmlassung at googlemail.com> wrote:
> So I managed to install pulseaudio 4.0 including sbc, speex, bluez and d-bus
> and I encounter the same problem. I installed D-feet to monitor dbus. This
> didn't really help move things forward as there's only listed what I already
> know from the python example. Play is not working here aswell as it's based
> on python again.
> Geez, I've been trying to make this work for about 2 weeks or more. Just to
> speak into my headset's microphone and to record it with linux. It worked
> exactly zero times.
> I ran out clocks, no solution in sight so far. Sigh.

As pointed out before, it seems your specific headsets presents issues
with BlueZ and/or PulseAudio, and I would suggest you test a different
headset to confirm this.

Perhaps I'm wrong but I believe there's no easy way to make you
headset work. If you really want to go deep into this issue, you'd
have to write or test a few PulseAudio patches, until the issue gets
fixed or at least the root cause is identified. But beware that this
will require a considerable time.


More information about the pulseaudio-discuss mailing list