[pulseaudio-discuss] HDMI audio passthrough no longer working

Xamindar junkxamindar at gmail.com
Sun Mar 1 23:47:35 PST 2015

On 03/01/2015 11:39 PM, Alexander E. Patrakov wrote:
> 02.03.2015 12:32, Xamindar wrote:
>> Hi Pulseaudio list!
>> With a recent update to my Arch system, audio passthrough has stopped
>> working in Kodi. Kodi no longer shows the passthrough options anymore
>> either. Here is what I have which has been working fine up until 
>> recently.
>> -7.1 audio out HDMI (nvidia card) to an Onkyo receiver.
>> -KDE4 running as my DE with pulseaudio configured and working.
>> -Pulseaudio set up as the correct 7.1 audio (even get them all in kde)
>> with passthrough items all checked in pavucontrol.
>> I was getting passthrough on the files that had supported codecs and
>> kodi was handling everything else. Then when I wasn't in Kodi audio was
>> great in the DE with all other applications. This set up was working
>> great up until recently. It's as if pulseaudio has stopped supporting
>> passthrough or my config got overwritten by a default.
>> Anyway, a recent update broke all this and the passthrough options have
>> vanished from the kodi options. The closest I have gotten is setting
>> sound configuration to stereo in pavucontrol and then the passthrough
>> options magically appear in kodi again. But still no sound on
>> passthrough stuff and this option is unacceptable anyway as I don't want
>> to reduce everything else to stereo just to get passthrough working in
>> one app.
>> Any ideas what went wrong here? Is there a known bug in pulseaudio 6.0
>> that causes this breakage?
> I have read the above, but the main question is unsnswered. Did it 
> work before with non-stereo profiles?
> My guess so far is that it never worked, and you broke it by enabling 
> the 7.1 profile that was not available before (i.e. I guess that you 
> were using a stereo profile before).
Sorry I wasn't clear. Yes it was all working with 7.1 before. I have 
made no changes other than a normal system update (pacman -Syu) so I do 
not understand why it has stopped working. In fact, I have had 7.1 
working on this system for more than a couple of years now. I originally 
got it working way back when pulseaudio woudn't even show anything 
beyond 5.1 by editing some extra-hdmi.conf file or somesuch in the 
pulseaudio system directory to add the extra speakers. I can't seem to 
be able to find that file on my system anymore however. But I remimber 
it having a LOT of stuff in it.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20150301/4cbdbea3/attachment.html>

More information about the pulseaudio-discuss mailing list