[pulseaudio-discuss] Overriding DONT_MOVE flag.

Mario Sottile - Marionetas Mey mariomey at gmail.com
Sat May 9 19:40:56 UTC 2020

Hello, there. I'm using Zoom (conference meeting software) for Linux 
(Debian 10 Buster x64). When Zoom is running, I need to move its Source 
Input to another Source... andit is not possible, because it has the 
flag DONT_MOVE. I tried all this:

· Changed or or created these files:


     allow-moves = yes # (or true or 1)

· Built OpenAL 1.20.1 (I had 1.19.1 from system) and installed:

     cmake ..
     sudo make install
     ldconfig -v
     # also...
     sudo ln -s /usr/local/lib/libopenal.so.1.20.1 
     sudo ln -s /usr/local/lib/libopenal.so.1.20.1 
     # also rebooting...

Also tried the alsoft-config 1.20.1 that does have the "Allow moving 
streams" option (the 1.19 didn't have it) and checked it...

NOTHING. Zoom still has the control of that stream.
What else can I do to achieve this?

The purpose of doing this is because, sometimes and suddenly, the audio 
starts with a 2-3 seconds lag. I think this cames from somewhere in 
PulseAudio. I've created a module-remap-sink to connect audio out 
monitor to Zoom, because I'm using OBS to send audio/video to it. So, I 
want to unload that module-remap-sink without crashing Zoom (in fact, a 
crash occurrs when doing that). And then, create the module again and 
creconnect Zoom to it.

Thanks in advance.

Marionetas Mey

Mario Sottile - Director
(011) 15.6283.1576
info at mariomey.com.ar

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20200509/192cedb7/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: firma.png
Type: image/png
Size: 4902 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20200509/192cedb7/attachment.png>

More information about the pulseaudio-discuss mailing list