[virglrenderer-devel] [RFC PATCH 0/7] re-unify caps GL and GLES evaluation code path
Gert Wollny
gert.wollny at collabora.com
Mon Jul 23 10:37:58 UTC 2018
Dear all,
currently, GL and GLES use partially different code path to query and set caps,
and given the solution choosen for filling capset_v2 this lead to some required
code duplication. This series is a stab at getting rid of thís duplication and
being a bit more accurate in querying the caps.
Especially the last part of this series, where I try to clean up setting certain
bits based on the gl/gles version or extensions will be made obsolete by Dave's
approach to fill these bits, but at least it gives a better with which values we
will need to fill this lookup table.
This series is against master, a tree that does the same thing for Dave's
experimental branch and that sets the required caps to expose GLES 3.1 on a
GLES 3.1 host can be found here:
https://gitlab.freedesktop.org/gerddie/virglrenderer/tree/gerddie-wip-gles31
A mesa branch for testing that uses the right caps definitions is here:
https://gitlab.freedesktop.org/gerddie/mesa/tree/gerddie-gles31-wip2
(but don't expect too much, there are some texture format problems)
Any comments welcome,
Gert
Gert Wollny (7):
vrend: remove superflous caps initialization
vrend caps: move some common caps to main routine
vrend caps: order caps that have versions or extensions versus general
caps
vrend caps: move more common code into main caps routine and only
handle
vrend caps: move GL/GLES duplicates into main function
vrend caps: remove gles caps code path
vrend caps: unify caps and remove some duplications
src/vrend_renderer.c | 346 ++++++++++++++++++---------------------------------
1 file changed, 120 insertions(+), 226 deletions(-)
--
2.16.4
More information about the virglrenderer-devel
mailing list