[virglrenderer-devel] Strange graphical glitches under virgl.

Lepton Wu lepton at chromium.org
Mon Jul 23 21:13:52 UTC 2018

Hi Gert,
Thanks for trying to reproduce it. I really appreciate your help on this issue.

FYI, I just tried on 2 different linux desktop with different host gpu
and I can reproduce on both machines. Since you can't reproduce it,
this could be
something related with  my guest. Here is my setup:

1. Both desktop runs Debian stretch.
2. One desktop come with amd rx480 gpu and I install amd-gpu-pro
driver on it. Another desktop just come with integrated intel gpu
(intel G4600 CPU) and I am just using default
mesa driver come with debian distribution.
3. I just install libepoxy-dev from debian official repo which is
version 1.3.1-2
4. For virglrenderder, I just get code from git and then do this :
"git checkout -b buggy be3b107", this is the last commit before the
glCopyimagesubdata change.
5. For qemu, I compile it like this:
    export PKG_CONFIG_PATH=$HOME/virgl/lib/pkgconfig
     ./configure --target-list=x86_64-softmmu --disable-gtk
--enable-virglrenderer --audio-drv-list=pa
6. For guest, as I said before, it's a chrome os guest. It can be get like this:
    wget https://storage.googleapis.com/chrome_os_emulator/sysimg_67-10575.63.0.zip
    unzip -x sysimg_67-10575.63.0.zip
    qemu-img convert -O raw x86/userdata.img rawdata.img
    cat x86/system.img rawdata.img x86/vendor.img > disk.img
 7. I am running qemu with the following flags:
     qemu-img create -f qcow2 -b disk.img disk.img.qcow2
     x86_64-softmmu/qemu-system-x86_64 -soundhw hda -enable-kvm -m
4096 -net nic,model=virtio -net user,hostfwd=tcp:
-device virtio-vga -display sdl,gl=on -device usb-ehci -device
usb-tablet -show-cursor -smp 4 disk.img.qcow2

    At the login screen,  it will ask for gmail account,  I just skip
this step by click "More options", and then click "Guest mode".

On Sun, Jul 22, 2018 at 4:35 AM Gert Wollny <gert.wollny at collabora.com> wrote:
> Am Freitag, den 20.07.2018, 14:12 -0700 schrieb Lepton Wu:
> > Hi,
> >
> > I have an issue which I recorded a video  to show the bug:
> > https://youtu.be/ECGDCMAOTxs
> > You can see, sometimes, there is a "wrong block" of rendering. It's
> > always some kind of rectangle somewhere.
> > A strange part is: I've never seen this kind of issue if I am running
> > 3D android games under virgl. Games always
> > running fine. But for Chrome, it sometimes come with this kind of
> > weird graphics.
> I was not able to reproduce the issue.
> I used the latest master of virglrenderer and mesa on an Intel Kabylake
>  host, and disabled the copy_image copy path via
> so that virglrenderer could not use this shortcut for copy-blits.
> Inside the guest I used Ubuntu bionic with the latest updates and a PPA
>  kernel: Linux version 4.16.0-041600-generic (kernel at kathleen)
> (4.16 is needed to support report host caps v2 to the guest).
> I tried both blackbox and a gnome-session with chromium-browser and I
> didn't seen any of these artifacts. What is actually the desktop
> environment that you were using?
> best,
> Gert

More information about the virglrenderer-devel mailing list