Rename text_model and text_model_factory?

Michael Hasselmann michaelh at
Sat Feb 2 04:39:01 PST 2013


Shouldn't the naming for the complementary interfaces in Weston's
protocol/text.xml and protocol/input-method.xml be more consistent?

For instance, there's text_model and text_model_factory interfaces in
text.xml, but in input-method.xml, the corresponding interfaces are
called input_method_context (~ text_model) and input_method (~

ciao Michael

More information about the wayland-devel mailing list