weston freezes up my system when run it in a separate VT with a normal config file

Kristian Høgsberg hoegsberg at gmail.com
Thu Feb 14 09:24:16 PST 2013

On Wed, Feb 13, 2013 at 08:50:39PM +0000, Rune Kjær Svendsen wrote:
> Through trial-and-error editing the config file, I've found that this is
> caused by the "keymap_layout=en" line in weston.ini. No freeze when this is
> commented out.
> Because of this line weston tries to read /usr/share/X11/xkb/symbols/en
> which doesn't exist, and it freezes, or at least makes me unable to switch
> to a different VT or do anything besides reboot with Alt+SysRq+REISUB. If I
> change the line to "keymap_layout=dk" there is no freeze
> (/usr/share/X11/xkb/symbols/dk exists).

Ah, I see... we have a rogue exit(1)s in the keyboard init path.  All
of these cases should return an error instead of exiting, which will
leave your system locked up (in KD_GRAPHICS mode with keyboard turned
off).  That would be a good thing to audit and clean up.


> Med venlig hilsen,
> Rune Kjær Svendsen
> Østerbrogade 111, 3. - 302
> 2100 København Ø
> Tlf.: 2835 0726
> On Tue, Feb 12, 2013 at 10:06 PM, Rune Kjær Svendsen <runesvend at gmail.com>wrote:
> > Hello
> >
> > I'm trying to use weston with a config file but failing, since it freezes
> > up my system when I do this. I'm attaching the config file. The specified
> > background does exist, although the icons don't. Running weston in a gnome
> > terminal works fine; the background is applied correctly and it runs fine
> > (although the launcher icons show X's). It's only when I run it on a
> > separate VT the freeze occurs.
> >
> > The freeze happens a different times while weston is filling the display
> > for the first time. If I just run weston-launcher it will freeze after the
> > "initializing drm backend" message in the console and stay there, although
> > it seems the top of the screen is also filled up somewhat it this point.
> > When I run it through strace, the screen gets to black with a cursor in the
> > upper left corner. I've also tried to have the interface appear and it
> > freezing immediately after that. Caps lock and num lock don't have an
> > effect on the LED indicators on my keyboard. Restarting weston with
> > Ctrl+Alt+Backspace doesn't work, Ctrl+Alt+Del doesn't work, but
> > Alt+SysRq+REISUB does restart the system.
> >
> > I have a Radeon HD 5770 GPU, and I'm using the drivers for this, and
> > wayland/weston, from the xorg-edgers PPA for Ubuntu 12.10. I'm attaching
> > the output of stracing the freeze.
> > Hope you guys have some ideas on what could be wrong.
> >
> > Cheers,
> > Rune
> >

> _______________________________________________
> wayland-devel mailing list
> wayland-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/wayland-devel

More information about the wayland-devel mailing list