855GM vga out 1680x1050 does not work (i810 driver)

Tero Laitinen tero.laitinen at iki.fi
Mon Nov 6 11:11:06 PST 2006


I am having problems getting the native resolution (1680x1050) to show
up in my Acer AL2216WD TFT screen attached to my laptop's (Asus M5642)
VGA port in Linux. I was able to get this resolution to work with
Intel's Windows drivers but not with Windows' default display
properties configurator.

The resolution 1280x1024 works fine without any tweaking but looks
really ugly because of the skewed aspect ratio and stretched image. I
would really like to enjoy every pixel on the screen.

First, I tried just adding a line

Modes "1680x1050"

to the section "Screen" of the file /etc/X11/xorg.conf but the result
was a text "Input Not Supported" floating in the screen. I tried adding
a modeline based on the Xorg's log file /var/log/Xorg.0.log:

(II) I810(0): Supported additional Video Mode:
(II) I810(0): clock: 146.2 MHz   Image Size:  473 x 296 mm
(II) I810(0): h_active: 1680  h_sync: 1784  h_sync_end 1960 h_blank_end
2240 h_border: 0
(II) I810(0): v_active: 1050  v_sync: 1053  v_sync_end 1059 v_blanking:
1089 v_border: 0
(II) I810(0): Ranges: V min: 56  V max: 76 Hz, H min: 30  H max: 82
kHz, PixClock max 210 MHz

Unfortunately, that did not help. I saved Xorg's log file of that try
to http://www.iki.fi/tol/xlogi1.txt . I googled a bit and found out
that VBIOS of my display adapter does not know anything about the
resolution 1680x1050. As apparently i810 driver uses BIOS calls to
change the resolution of the adapter, it needs the resolution to be
listed in VBIOS if I understood correctly.

I found a utility called 915resolution which can overwrite useless
modes with different resolutions. The programs finds following video
modes by default:

Intel 800/900 Series VBIOS Hack : version 0.5.2

Chipset: 855GM
Mode Table Offset: $C0000 + $36f
Mode Table Entries: 21

Mode 30 : 640x480, 8 bits/pixel
Mode 32 : 800x600, 8 bits/pixel
Mode 34 : 1024x768, 8 bits/pixel
Mode 38 : 1280x1024, 8 bits/pixel
Mode 3a : 1600x1200, 8 bits/pixel
Mode 3c : 1920x1440, 8 bits/pixel
Mode 41 : 640x480, 16 bits/pixel
Mode 43 : 800x600, 16 bits/pixel
Mode 45 : 1024x768, 16 bits/pixel
Mode 49 : 1280x1024, 16 bits/pixel
Mode 4b : 1600x1200, 16 bits/pixel
Mode 4d : 1920x1440, 16 bits/pixel
Mode 50 : 640x480, 32 bits/pixel
Mode 52 : 800x600, 32 bits/pixel
Mode 54 : 1024x768, 32 bits/pixel
Mode 58 : 1280x1024, 32 bits/pixel
Mode 5a : 1600x1200, 32 bits/pixel
Mode 5c : 1920x1440, 32 bits/pixel
Mode 7c : 1024x600, 8 bits/pixel
Mode 7d : 1024x600, 16 bits/pixel
Mode 7e : 1024x600, 32 bits/pixel

I tried overwriting mode 50 with command 915resolution 50 1680 1050.
The command succeeds and after that the resolution 1680x1050 appears in
the list. I tried to start Xorg but this time the result was different.
A text "No Signal" was shown in the screen.
I saved Xorg's log file to http://www.iki.fi/tol/xlogi2.txt

I upgraded the kernel to newest just in case it might help but 
of course it did not.

My Xorg's configuration file is at http://www.iki.fi/tol/xorg.conf.txt
My display adapter's name is "Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02)"

As Windows drivers can make it work, I am sure that it is possible  :) .
I wanted to try Intel's drivers but the git repository was down at the

$ git-clone git://anongit.freedesktop.org/git/mesa/drm
fatal: unable to connect a socket (Connection refused)

So, I would really appreciate any advice you may have to get the native
resolution working in Linux.

Thank you in advance,
Tero Laitinen

More information about the xorg mailing list