855GM vga out 1680x1050 does not work (i810 driver)

Colin Guthrie gmane at colin.guthr.ie
Mon Nov 6 11:36:25 PST 2006

Tero Laitinen wrote:
> Hi,
> I am having problems getting the native resolution (1680x1050) to show
> up in my Acer AL2216WD TFT screen attached to my laptop's (Asus M5642)
> VGA port in Linux. I was able to get this resolution to work with
> Intel's Windows drivers but not with Windows' default display
> properties configurator.
> I found a utility called 915resolution which can overwrite useless
> modes with different resolutions. The programs finds following video
> modes by default:

You are on the right track with 915 resolution. For me I installed it
and my Xorg "just worked". This was in Mandriva 2007/Cooker

> I tried overwriting mode 50 with command 915resolution 50 1680 1050.
> The command succeeds and after that the resolution 1680x1050 appears in
> the list. I tried to start Xorg but this time the result was different.
> A text "No Signal" was shown in the screen.

I didn't specify the mode to override, just the resolution I wanted and
915resolution automatically picked the right mode(s) to override. It
made sure that my desired resolution was also inserted at multiple
colour depths which was nice.

> I saved Xorg's log file to http://www.iki.fi/tol/xlogi2.txt

>From the log it's seeing your new mode 50... which is good.

> My Xorg's configuration file is at http://www.iki.fi/tol/xorg.conf.txt

It looks like you picked a default colour depth of 24 bits... In your
log it only seems to list 1680x1050 at 8, 16 and 32 bit depths..

Perhaps this is why it's not matching??

Try changing it to 32 bit in your xorg.conf...


More information about the xorg mailing list