[Uim] QT-immodule: Unable to type characters with accents

David Oftedal david at start.no
Tue Jun 1 21:34:25 EEST 2004

> No... I tried Norwegian layout but it didn't work either.  It seems 
> the problem had something to do with my locale, that is, a mixing of 
> ja_JP and en_US.  I created a new user with French locale, then I got 
> all accented characters (even "œ") and dead keys worked in all 
> applications I tried.  But when I changed input method to uim-anthy 
> in qtconfig, I got "^a" again! :( The strange thing is, dead keys are 
> still working in OpenOffice Writer, though I can't type Japanese 
> there.

AH! I have an idea.

Have you tried using UTF-8? I use that for all locales on my system, as 
long as my libc supports it. I even generated them manually by issuing 
the following commands as the superuser:

localedef -f UTF-8 -i ja_JP ja_JP.utf8
localedef -f UTF-8 -i en_US en_US.utf8

libc won't support UTF-8 for all locales, but I think it works for both 
ja_JP and en_US.


More information about the uim mailing list