[pulseaudio-discuss] Need help to enable echo cancel in pulseaudio

ABDUL MOIZ abdulmoiz786 at gmail.com
Fri Jul 22 02:02:36 PDT 2011

       Thanks for the reply.

       As adviced by you,I have followed the procedure given in the link


      I got the code from the git source as told in the guide and everything
was going well but i got error at this step

        $ src/pulseaudio -n -F src/default.pa -p $(pwd)/src/.libs/ -vvvv

 You can check the attached log file to see the error.

 Then I have again restarted the build process by giving the path to be /usr
while configuring  i.e

       $ ./configure --prefix=/usr

 And the build was successful, and I can able to run the pulseaudio daemon.

In the CLI terminal, i have changed the default source and sink to echo
cancel as shown below:

<<set-default-source alsa_input.pci-0000_00_1b.0.analog-stereo.echo-cancel
<<set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo.echo-cancel

Now when i test using gst pipeline, i can observe that echo & noise has been
To confirm whether echo cancel is working or not , i tried to see verbose
log as shown below:

$ pulseaudio -v

But I am getting the following:

I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: core-util.c: Successfully gained nice level -11.
I: main.c: This is PulseAudio 0.98-dev-438-g6add-dirty
I: main.c: Page size is 4096 bytes
I: main.c: Machine ID is fstl-laptop.
I: main.c: Session ID is
I: main.c: Using runtime directory /home/fstl/.pulse/fstl-laptop-runtime.
I: main.c: Using state directory /home/fstl/.pulse.
I: main.c: Using modules directory /usr/lib/pulse-0.98/modules.
I: main.c: Running in system mode: no
E: pid.c: Daemon already running.
E: main.c: pa_pid_file_create() failed.

when i kill the pulseaudio daemon, then also the samething coming.
And also I have tried the below commands:

$ pulseaudio --kill
$ killall pulseaudio
$ killall -9 pulseaudio
$ rm -rf ~/.pulse*
$ sudo rm -rf /tmp/pulse*

But still "pulseaudio -v" is not working.
and "pulseaudio --kill" also being executed, but pulseaudio daemon is still

So the problem is pulseaudio instance is not getting killed properly.
Can you please help me to get clean start and kill of pulseaudio daemon and
as well as to get the log messages of running pulseaudio daemon.


Abdul Moiz

On Fri, Jul 22, 2011 at 1:28 AM, Colin Guthrie <gmane at colin.guthr.ie> wrote:

> 'Twas brillig, and ABDUL MOIZ at 21/07/11 08:06 did gyre and gimble:
> > Hi,
> >
> >       I have downloaded pulse audio source code from the link shown below
> >
> >
> http://cgit.freedesktop.org/pulseaudio/pulseaudio/commit/?id=0ecf51119a349e51daeea0437eba9a14d69ce533
> >
> > i have untar the file and have compiled and installed the pulseaudio by
> > following the steps below:
> I wouldn't generally recommend downloading tarballs from these links
> unless you know specifically what revision you want. After this commit
> has come in there have been various further fixes (almost 100 new
> commits!).
> So you should likely check out git master from git.
> I've got a guide here:
> http://colin.guthr.ie/2010/09/compiling-and-running-pulseaudio-from-git/
> > $:./bootstrap.sh
> > $:./configure
> > $:make
> > $;sudo make install
> This is quite dangerous. You are installing PA into /usr/local. This
> will almost certainly interfere with your distribution's PA version and
> generally cause you headaches unless you really know what you are
> doing!! In the link above I very specifically do not install PA but keep
> it in a separate tree and run it instead of my system one, but in a way
> that does not interfere.
> But all these warnings aside, you appear to have got it working....
> > Pulseaudio has been installed and i have started the daemon using
> >
> > $:pulseaudio --start
> >
> > I have loaded the echo-cancel module as shown below
> >
> > $:pactl load-module module-echo-cancel
> >
> > I have run the CLI and found the echo cancel module loaded as shown below
> >
> > $:pacmd
> > << list-modules
> >
> >  index: 17
> >     name: <module-echo-cancel>
> >     argument: <>
> >     used: 0
> >     load once: no
> >     properties:
> >         module.author = "Wim Taymans"
> >         module.description = "Echo Cancelation"
> >         module.version = "UNKNOWN"
> > <<
> >
> > I have connected mono mic to the pc
> > Now I have run the gstreamer pipeline to test the working of echo cancel
> > module
> >
> > $:gst-launch-0.10 pulsesrc ! pulsesink
> >
> > I am able to loopback my voice but still , echo is prevalant.
> > Can you please tell me how to check whether echo canceller has been
> > enabled or not and if it is not enabled then how to enable and run it.
> I'm not sure what's going on here or if this is a valid testing procedure.
> For example, are you definitely recording from the echo cancel source,
> or are you simply recording from the standard mic source.
> After launching this pipeline, I'd expect you'll have to move the
> recording stream to the right source for it to have any affect.
> That said, I've not done much playing with the echo cancel stuff, so
> perhaps Arun can advise better than me.
> Col
> --
> Colin Guthrie
> gmane(at)colin.guthr.ie
> http://colin.guthr.ie/
> Day Job:
>  Tribalogic Limited [http://www.tribalogic.net/]
> Open Source:
>  Mageia Contributor [http://www.mageia.org/]
>  PulseAudio Hacker [http://www.pulseaudio.org/]
>  Trac Hacker [http://trac.edgewall.org/]
> _______________________________________________
> pulseaudio-discuss mailing list
> pulseaudio-discuss at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/pulseaudio-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20110722/df3e912c/attachment-0001.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pulseaudio_buildlog
Type: application/octet-stream
Size: 11613 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20110722/df3e912c/attachment-0001.obj>

More information about the pulseaudio-discuss mailing list