[Pm-utils] Fwd: Suddenly lost the ability to suspend

Ryan Hughes ryan at iheartryan.com
Sat Feb 21 13:06:46 PST 2009

Hi.  I've got some more info.
I got out a backup drive that was made before, when sleep worked.  I can 
boot from it, and it can still sleep.  So that means there's some sort of 
software problem.  I looked through a bunch of files, and didn't see 
anything obvious.  I thought I'd send it along and see if someone here 
could help interpret the results, or knew of an additional source of info.

I attached two dmesg's:  One from when I booted from my backup, where 
sleep worked.  That's called dmesg.good.txt.  The other is from when I 
boot now, where sleep doesn't work.  That's called dmesg.bad.txt.

I took diffs of many commands.  They are attached.
One is 'dpkg -l', showing all the packages I have installed.

One is lsmod | sort.

There is no difference in uname -a.  That's:
 	Linux drawesome 2.6.22-14-generic #1 SMP Tue Feb 12 02:46:46 UTC 
2008 x86_64 GNU/Linux

I also included diff -Nru of the good /etc directory with that of my 
current /etc/ directory.

I edited out a little bit of sensitive information.  vpn config files and 
Note:  There's a lot of stuff in there about kvm.  But it turns out that 
my processor (an Intel Celeron) can't run kvm, so it is not actually 

So, I hope somebody can help me out.  If not, I will just have to 
reinstall my OS, as though this was Windows Vista or something.


On Tue, 3 Feb 2009, Ryan Jud Hughes wrote:

> Hi.  I've been running my laptop for about a year.  It's a Lenovo-branded
> Thinkpad R61.  For most of its life, everything went fine.  Suddenly,
> about a month ago, I lost the ability to suspend.
> I'm using Ubuntu 8.04, with a variety of their kernels, such as 2.6.22-14.
> I'd like to tell you what version of pm-suspend I'm using, but typing
> 'pm-suspend --version' causes the screen to go blank and bumps me to some
> blank virtual console or something.
> This is the same thing that happens when I use any combination of quirks
> I've tried.  I get bumped to some blank virtual console.  Perhaps VC 7
> without X graphics on it.  Hitting alt-F7 takes me back into X.  Nothing
> shows up in the syslog or in /var/log/pm-suspend.log.  The machine stays
> active.  The screen is on, it responds to ssh, all calculations continue.
> Just that slight bump to the graphics is the only way I know that anything
> at all has happened.
> The traditional quirks to use with this hardware platform are s3-mode and
> s3-bios.  That combination has the same results as any other combination.
> So what should I try?  How can I get some more information out of there?
> Do I need to set it to some sort of debug mode in order to get the
> debugging info?
> Thanks.
> --Ryan
> _______________________________________________
> Pm-utils mailing list
> Pm-utils at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/pm-utils
-------------- next part --------------
A non-text attachment was scrubbed...
Name: etc.edited.diff
Type: text/x-diff
Size: 22762 bytes
Url : http://lists.freedesktop.org/archives/pm-utils/attachments/20090221/f5f9ad53/attachment-0003.diff 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: lsmod.sort.diff
Type: text/x-diff
Size: 2417 bytes
Url : http://lists.freedesktop.org/archives/pm-utils/attachments/20090221/f5f9ad53/attachment-0004.diff 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dpkg-l.diff
Type: text/x-diff
Size: 25870 bytes
Url : http://lists.freedesktop.org/archives/pm-utils/attachments/20090221/f5f9ad53/attachment-0005.diff 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: dmesg.good.txt
Url: http://lists.freedesktop.org/archives/pm-utils/attachments/20090221/f5f9ad53/attachment-0002.txt 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: dmesg.bad.txt
Url: http://lists.freedesktop.org/archives/pm-utils/attachments/20090221/f5f9ad53/attachment-0003.txt 

More information about the Pm-utils mailing list