July 2015 Archives by thread
Starting: Wed Jul 1 00:16:39 PDT 2015
Ending: Fri Jul 31 19:46:46 PDT 2015
Messages: 673
- [RFC wayland 1/2] client: Introduce 'proxy wrapper' concept
Jonas Ådahl
- [PATCH wayland] shm: add getters for the fd and offset
Giulio Camuffo
- [PATCH weston 01/19] text-backend: Replace focus_listener_initialized with a bool
Jonas Ådahl
- [PATCH weston 02/19] exposay: Test keyboard presence before using keyboard pointer
Jonas Ådahl
- [PATCH weston 03/19] desktop-shell: make client_initiated a bool
Jonas Ådahl
- [PATCH weston 04/19] input: minor clean up in weston_seat_repick()
Jonas Ådahl
- [PATCH weston 05/19] bindings: Stop exporting internal functions
Jonas Ådahl
- [PATCH weston 06/19] compositor-drm: Simplify logic in setup_output_seat_constraint
Jonas Ådahl
- [PATCH weston 07/19] input: clean up notify_modifiers a little
Jonas Ådahl
- [PATCH weston 08/19] input: clean up update_keymap a little
Jonas Ådahl
- [PATCH weston 09/19] input: clean up seat_get_keyboard a little
Jonas Ådahl
- [PATCH weston 10/19] screenshooter: clean up recorder_binding a little
Jonas Ådahl
- [PATCH weston 11/19] input: Pass the appropriate pointer type to bindings instead of a seat
Jonas Ådahl
- [PATCH weston 12/19] desktop-shell: Make surface_touch_move take a touch instead of a seat
Jonas Ådahl
- [PATCH weston 13/19] desktop-shell: Make surface_move take a pointer instead of a seat
Jonas Ådahl
- [PATCH weston 14/19] desktop-shell: Make surface_rotate take a pointer instead of a seat
Jonas Ådahl
- [PATCH weston 15/19] desktop-shell: Make surface_resize take a pointer instead of a seat
Jonas Ådahl
- [PATCH weston 16/19] desktop-shell: Use the grabbed pointer in popup_grab_button
Jonas Ådahl
- [PATCH weston 17/19] bindings: make install_binding_grab take a keyboard instead of a seat
Jonas Ådahl
- [PATCH weston 18/19] bindings: Make run binding functions take apropriate device instead of a seat
Jonas Ådahl
- [PATCH v6 weston 19/19] input: Don't test keyboard/pointer/touch pointers
Jonas Ådahl
- [PATCH] xwayland: Always free reply from xcb_get_property_reply()
Marek Chalupa
- [PATCH wayland 3/3] shm: wl_shm_buffer_get_data() requires a valid pool.
Marek Chalupa
- [PATCH] weston-launch: Drop redundant exit()
Marek Chalupa
- [PATCH] scanner: Close input resource when done to prevent leak
Marek Chalupa
- [PATCH weston] clients: Simplify memory allocation with xzalloc()
Marek Chalupa
- [PATCH weston] logind-util: Use %u for unsigned int in snprintf
Marek Chalupa
- [PATCH 07/10] compositor-drm: Allow instant start of repaint loop. (v2)
Daniel Stone
- [PATCH weston v2 0/8] Generic Wayland dmabuf protocol
Pekka Paalanen
- [RFC libinput 0/9] touchpad: force resolutions for all touchpads
Bill Spitzak
- [PATCH] build: always build wayland-scanner
Ross Burton
- [PATCH libinput 5/9] udev: add Elantech touchpad firmware detection
Peter Hutterer
- [PATCH 03/10] cms-helper/static: Add "identity" builtin cms profile (v2)
Mario Kleiner
- [PATCH libinput 1/3] test: wait for the uinput_monitor on test devices
Peter Hutterer
- [PATCH 05/10] desktop-shell: Allow fullscreen windows to mode-switch their output.
Pekka Paalanen
- [PATCH weston v5 5/6] Converted the config parser test to the new framework.
Jon A. Cruz
- [PATCH libinput 00/11] Touchpad gestures final version
Peter Hutterer
- [PATCH weston v6 0/4] Refactored simple unit/integration test framework and corresponding test program.
Jon A. Cruz
- [PATCH weston v6 1/4] Added simple unit/integration test framework and corresponding test program.
Jon A. Cruz
- [PATCH weston v6 2/4] Enables output in the JUnit XML format.
Jon A. Cruz
- [PATCH weston v6 3/4] Converted the config parser test to the new framework.
Jon A. Cruz
- [PATCH weston v6 4/4] Adding doxygen setup and info for the testing framework.
Jon A. Cruz
- [PATCH] fixed-benchmark: remove unused arguments in main
Marek Chalupa
- cross-client surface references
Alexander Larsson
- [PATCH 09/10] presentation-shm: Allow setting of delay before surface.commit
Pekka Paalanen
- [PATCH libinput v3 5/5] libinput: add orientation and size of touch point and pressure to the API
Andreas Pokorny
- [weston][PATCH] compositor-fbdev: Add support grayscale PIXMAn_g4 format.
Enric Balletbo i Serra
- [ANNOUNCE] libinput 0.19.0
Peter Hutterer
- [PATCH libinput 1/3] test: move enable_edge_scroll up
Peter Hutterer
- [PATCH libinput] touchpad: be smarter about clickfinger thumb detection
Peter Hutterer
- [PATCH 0/2] Add support for multiple framebuffer outputs
Sjoerd Simons
- [PATCH 1/2] compositor-fbdev: Drop intermediate shadow buffer
Sjoerd Simons
- [PATCH 2/2] fbdev-compositor: enumerate framebuffer device using udev
Sjoerd Simons
- [PATCH 08/10] compositor: Respect repaint-window when restarting repaint loop.
Pekka Paalanen
- [PATCH libinput v4 0/5] add touch pointer properties
Andreas Pokorny
- [PATCH] screenshooter: correct output ordering of screencast recording when Y-flip is off
Tomohito Esaki
- [PATCH] screenshooter: Add missing field initializers for wl_output_listener
Christopher Michael
- [PATCH libinput 1/4] test: allow for a default value on LITEST_AUTO_ASSIGNS
Peter Hutterer
- [PATCH libinput 2/4] touchpad: add pressure-based thumb-detection
Peter Hutterer
- [PATCH weston] input: pass the global touch coordinates to the touch grab
Giulio Camuffo
- [PATCH libinput 1/9] udev: make sure the udev callout path is valid for a test run
Hans de Goede
- [PATCH libinput 2/9] evdev: simplify setting a fake resolution
Hans de Goede
- [PATCH libinput 3/9] util: add a helper function to parse a "WIDTHxHEIGHT" property
Hans de Goede
- [PATCH libinput 4/9] evdev: use LIBINPUT_ATTR_SIZE_HINT for resolutions
Hans de Goede
- [PATCH libinput 6/9] udev: add ALPS firmware detection and size properties
Hans de Goede
- [PATCH libinput 7/9] udev: add size hint for apple touchpads
Hans de Goede
- [PATCH libinput 8/9] touchpad: default to a 69x50mm sized touchpad
Hans de Goede
- [PATCH libinput 9/9] touchpad: drop fake resolution handling
Hans de Goede
- [PATCH weston 02/11] compositor: add API to manage compositor instances
Pekka Paalanen
- [PATCH] documentation: Update documentation for calling wl_display_sync
Christopher Michael
- [PATCH weston v3 01/11] compositor: introduce struct weston_backend
Pekka Paalanen
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Christopher Michael
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Jasper St. Pierre
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Giulio Camuffo
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Christopher Michael
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Christopher Michael
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Pekka Paalanen
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Bryce Harrington
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Bryce Harrington
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Christopher Michael
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Bryce Harrington
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Pekka Paalanen
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Bryce Harrington
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Pekka Paalanen
- [PATCH] Documentation for the prepare_lock_surface event description, is incorrect
Bryce Harrington
- [PATCH] xwayland: Check return of xcb_get_property_reply() before deref
Bryce Harrington
- [PATCH libinput] evdev: parse LIBINPUT_ATTR_RESOLUTION_HINT
Peter Hutterer
- [PATCH] tests: Don't increment variables inside an assert()
Bryce Harrington
- [PATCH weston v3 02/11] compositor: add API to manage compositor instances
Pekka Paalanen
- [PATCH weston v3 03/11] compositor: move the main() to a new main.c file
Pekka Paalanen
- [PATCH weston 04/11] make the backends compositor-neutral
Pekka Paalanen
- [PATCH weston v3 04/11] make the backends compositor-neutral
Pekka Paalanen
- [PATCH v2 weston 01/16] compositor-drm: Refactor initial mode out of create_output
Bryce Harrington
- [PATCH v2 weston 02/16] compositor-drm: Refactor connector name into new function
Bryce Harrington
- [PATCH v2 weston 04/16] compositor-drm: Record current DPMS level
Bryce Harrington
- [PATCH v2 weston 00/16] Atomic modesetting support
Bryce Harrington
- [PATCH] xwayland: Allow dump_property when selection fails
Bryce Harrington
- [PATCH weston] compositor-wayland: Use the correct list pointer when freeing shm buffers
Bryce Harrington
- [PATCH] screen-share: Use the correct list pointer when freeing shm buffers
Bryce Harrington
- [PATCH weston v2] logind-util: Use %lu for unsigned int in snprintf
Bryce Harrington
- [PATCH weston v2] compositor: make sure to reset views' pointers to destroyed output
Giulio Camuffo
- [PATCH v2 wayland] protocol: add wl_pointer.axis_frame events
Jonas Ådahl
- [PATCH weston] configure.ac: add support for new versions of systemd
Frederico Cadete
- [PATCH libinput 1/2] Add a configuration interface for enabling/disabling disable-while-typing
Peter Hutterer
- [PATCH weston v3 06/11] build a libweston.so used by the weston binary
Pekka Paalanen
- [PATCH weston 1/3] zunitc: wrap dox to 80 columns
Bryce Harrington
- [PATCH weston 2/3] zunitc: Fix some minor grammatical errors in dox
Bryce Harrington
- [PATCH weston 3/3] zunitc: Fix minor typo
Bryce Harrington
- [PATCH libinput] touchpad: disable 2fg scrolling on semi-mt touchpads
Peter Hutterer
- [PATCH libinput 1/2] touchpad: make the edge-scroll edge 7mm wide
Peter Hutterer
- Wayland Relative Pointer API Progress
x414e54
- [PATCH weston] README: introduce libweston
Pekka Paalanen
- libinput / weston-terminal : missing the caret char in the terminal (^)
Pekka Paalanen
- [PATCH v3 weston] Introduce wl_relative_pointer interface
x414e54
- [PATCH libinput] touchpad: drop thumb handling from gestures
Peter Hutterer
- [PATCH wayland] protocol: define further the behavior of input on the presence of grabs
Peter Hutterer
- Compositor grabs (was: Re: [PATCH] protocol: Add DnD actions)
Peter Hutterer
- [PATCH] ivi-shell: remove one indent level from update_prop()
Nobuhiko Tanibata
- [PATCH weston 0/2] transform refactoring in ivi-shell
Nobuhiko Tanibata
- [PATCH v2 2/3] xwayland: Remove a useless out-of-memory check
Marek Chalupa
- [PATCH v2 3/3] xwayland: Destroy xwl_output when wl_output gets removed
Marek Chalupa
- [PATCH xwayland v2] xwayland: do not add output into output_list multiple times
Marek Chalupa
- [PATCH weston 00/17] Don't allow direct use of seat->device pointers
Derek Foreman
- [PATCH v2 weston 01/17] text-backend: Replace focus_listener_initialized with a bool
Derek Foreman
- [PATCH v2 weston 02/17] exposay: Test keyboard presence before using keyboard pointer
Derek Foreman
- [PATCH v2 weston 03/17] bindings: Stop exporting internal functions
Derek Foreman
- [PATCH v2 weston 04/17] compositor-drm: Simplify logic in setup_output_seat_constraint
Derek Foreman
- [PATCH v2 weston 05/17] input: Pass the appropriate pointer type to bindings instead of a seat
Derek Foreman
- [PATCH v2 weston 06/17] desktop-shell: Make surface_touch_move take a touch instead of a seat
Derek Foreman
- [PATCH v2 weston 07/17] desktop-shell: Make surface_move take a pointer instead of a seat
Derek Foreman
- [PATCH v2 weston 08/17] desktop-shell: Make surface_rotate take a pointer instead of a seat
Derek Foreman
- [PATCH v2 weston 09/17] desktop-shell: Make surface_resize take a pointer instead of a seat
Derek Foreman
- [PATCH v2 weston 10/17] desktop-shell: Use the grabbed pointer in popup_grab_button
Derek Foreman
- [PATCH v2 weston 11/17] bindings: make install_binding_grab take a keyboard instead of a seat
Derek Foreman
- [PATCH weston 13/17] input: Check device counts in bind_seat()
Derek Foreman
- [PATCH weston 14/17] desktop-shell: Don't call wl_list_init() in the middle of a list
Derek Foreman
- [PATCH weston 15/17] desktop-shell: Check for device presence properly
Derek Foreman
- [PATCH weston 16/17] fullscreen-shell: Test for device presence properly
Derek Foreman
- [RFC] Pointer gestures protocol
Carlos Garnacho
- [PATCH weston 1/4] compositor: Implement wl_pointer_gesture_swipe/pinch interfaces
Carlos Garnacho
- [PATCH] Partially revert "xwayland: Always free reply from xcb_get_property_reply()"
Emmanuel Gil Peyrot
- [ANNOUNCE] libinput 0.20.0
Peter Hutterer
- [PATCH] wayland-server: Fix null pointer dereferencing
Ashim
- weston-desktop-shell
Nancy Zou
- [PATCH wayland 1/2] scanner: refactor creating objects and get rid of leaks
Marek Chalupa
- [PATCH wayland v2] protocol: Add pointer gestures (swipe/pinch) protocol
Carlos Garnacho
- [PATCH][weston] build: don't duplicate rule for weston.desktop
Ross Burton
- [PATCH][weston] build: mkdir target weston.ini directories before writing
Ross Burton
- [PATCH v2 weston] log: Open log file CLOEXEC so child processes don't get the fd
Bryce Harrington
- [PATCH weston] shell: Switch middle and right mouse bindings
Bryce Harrington
- [PATCH] compositor: destroy modifier_binding_list
Ryo Munakata
- [PATCH][V3][weston] build: mkdir target weston.ini directories before writing
Ross Burton
- Patchwork upgrade?
Bryce Harrington
- [PATCH 10/10] cms-colord: Fix crash at compositor shutdown.
Derek Foreman
- Report: Patches that no longer apply
Bryce Harrington
- [PATCH weston] exposay: Fix logic inversion when ending keyboard grabs
Derek Foreman
- [PATCH] cms-colord: Fix crash at compositor shutdown. (v2)
Mario Kleiner
- [PATCH] cms-helper/static: Add "identity" builtin cms profile (v3)
Mario Kleiner
- [PATCH libinput] Code cleanup
Thomas Hindoe Paaboel Andersen
- [PATCH v2 libinput] code cleanup
Peter Hutterer
- [PATCH 0/2] Misc fixes for the RDP compositor
David FORT
- [PATCH weston] desktop-shell: Put monitor to sleep when idle timer expires
Derek Foreman
- [PATCH libinput 0/4] Fix synaptics cursor jumps for triple-touches
Peter Hutterer
- [PATCH libinput 1/2] touchpad: reduce 2fg scroll threshold to 2mm
Peter Hutterer
- LibreOffice now works natively on wayland
darxus at chaosreigns.com
- [PATCH libinput 01/11] touchpad: skip thumb detection for touchpads smaller than 50mm
Peter Hutterer
- announcing wldbg
Marek Chalupa
- [PATCH libinput 1/3] test: only initialize the generic rules/hwdb once
Peter Hutterer
- [PATCH v2 weston 0/4] Some zoom fixes
Derek Foreman
- [PATCH wayland] build: Build libwayland-private
Bryce Harrington
- [PATCH libinput] touchpad: don't check clickfinger distance for three fingers
Peter Hutterer
- Libinput: Halfkey/Mirrorboard implementation
Kieran Bingham
- [PATCH weston] compositor: remove a call to weston_compositor_schedule_repaint
Ryo Munakata
- [PATCH libinput 1/5] test: Use ck_assert_double_ for checking doubles in some places
Jonas Ådahl
- [PATCH libinput 1/2] test: Make udev path variables more explicitly named
Jonas Ådahl
- [PATCH wayland 1/2] Extend WAYLAND_DISPLAY and name parameter semantics to support absolute paths.
Davide Bettio
- [PATCH wayland] Introduce WAYLAND_SERVER_SOCKET_DIR to change socket directory without changing XDG_RUNTIME_DIR.
Davide Bettio
- [PATCH libinput] touchpad: drop distance threshold to detect pinches
Peter Hutterer
- [PATCH libinput] test: add a bunch of libinput_dispatch() before timeout calls
Peter Hutterer
- [PATCH weston] Update .gitignore
Dawid Gajownik
- [PATCH libinput 1/2] test: add missing libinput_dispatch() before timeouts
Peter Hutterer
- [PATCH libinput] gestures: check ntouches, not just num_slots for the number of fingers
Peter Hutterer
- [PATCH] desktop-shell: fix bug referencing invalid surface list
Ryo Munakata
- [PATCH? weston] - wayland backend: outputs are destroyed twice
Dawid Gajownik
- [RFC wayland 1/2] doc: Add a paragraph about the object creation guarantee
Jonas Ådahl
- [PATCH libinput 1/6] test: move the helper functions to the litest.h file
Peter Hutterer
- [PATCH libinput 2/6] touchpad: move CAP_GESTURE assignment to the touchpad code
Peter Hutterer
- [PATCH] xwayland-input: Always set the xkb group index on modifiers events
Marek Chalupa
- [PATCH wayland] scanner: check sanity of version
Marek Chalupa
- XDC2015 - Travel sponsorship
Martin Peres
- [PATCH weston] compositor: fix crash when destroying incompletely created output
Dawid Gajownik
- [PATCH libinput 1/3] tools: fix the velocity range for printing the ptraccel profile
Peter Hutterer
- [PATCH wayland] wayland-client : Fix duplicated proxy destroy
Elvis Lee
- How can an X11 tell it's running in XWayland?
Olivier Fourdan
- [PATCH wayland] wayland-client : Fix queue_release not to call proxy_destroy
Elvis Lee
- [PATCH weston v3 1/5] protocol: Add _wl_pointer_gestures (swipe/pinch) protocol
Carlos Garnacho
- [PATCH weston] main: update RDP backend help message
Dawid Gajownik
- [PATCH weston] main: print backends in help message in alphabetical order
Dawid Gajownik
- [PATCH weston] .gitignore: ignore doxygen generated files v2
Dawid Gajownik
- [PATCH weston] compositor-rdp: rdp_destroy() double free error #91457
Dawid Gajownik
- [PATCH weston] screen-share: don't test keyboard/pointer pointers
Dawid Gajownik
Last message date:
Fri Jul 31 19:46:46 PDT 2015
Archived on: Fri Jul 31 19:47:22 PDT 2015
This archive was generated by
Pipermail 0.09 (Mailman edition).